We’re currently investigating issues with the SOS Report appearing blank, Adventure Sync not working (Android), and in-app purchasing (iOS.) Visit this post for more details
iOS Purchasing Issues in Wizards Unite - Page 2 — Harry Potter: Wizards Unite Community Forum

iOS Purchasing Issues in Wizards Unite

245

Comments

  • SuperDRMSuperDRM Posts: 1
    #3228 December, 2020, 02:55 am.

    I was able to login to my account on another iPhone and buy some items. It’s not ideal, but it worked for me.

  • DrakoniteDrakonite Posts: 821 ✭✭✭✭
    #3629 December, 2020, 07:49 pm.

    The answer to unable to purchase items https://www.reddit.com/r/TheSilphRoad/comments/km4w10/comment/ghcrq5u

    This has worked out for a few ppl in iOS and it seems to be a perm. fix. (in WU as well not only POGO).

  • DottydominoDottydomino Posts: 4 ✭✭
    #3829 December, 2020, 08:46 pm.

    I have been having issues with the app for months so much so I gave up playing. As I was stuck in a restart loop. Managed to get in and found I was unable to buy or collect anything. Up until that point I had been playing every single day. Have an iPhone 7 on the recent iOS.


    been a pile of poop for a while now.


    I hope you fix it soon

  • Jenv45Jenv45 Posts: 6 ✭✭
    #4029 December, 2020, 10:11 pm.

    I have logged in and out of everything possible, I had Apple check my download queue, and it is still not working for me. Please, PLEASE, provide an update so we know how long before a permanent fix is available!!!

  • SilrunRendSilrunRend Posts: 1
    #4129 December, 2020, 10:23 pm.

    How do we purchase?

  • Antique100Antique100 Posts: 14 ✭✭
    #4229 December, 2020, 11:38 pm.

    @KATclaw13


    Thank you!!


    I discovered that I was already unlinked from Apple .


    Then, as long as I was unlinked from the Ap Store Media & Purchases, I could claim the 12 Tasks free basket and buy the expanded spell energy capacity (or anything else) with the gold I already had.

  • Antique100Antique100 Posts: 14 ✭✭
    #4330 December, 2020, 12:22 am.

    @KATclaw13


    And, thank you again!


    By staying unlinked from Apple (which is my default) and staying with the Ap Store Media & Purchases turned off, I was able to buy gold coins. Making the gold purchase required inputting my Apple id and password, but that is easy.


    The workaround requires steps, but now I can buy what I want in Wizards. All good. Having to wait until WU/Apple fix this (presumably sometime after January 4th when their staff goes back to work), was not good at all.

  • LalalaHDLalalaHD Posts: 1 ✭✭
    #4430 December, 2020, 01:21 am.

    Why were we able to have support manually award the complimentary gift earlier in the month but not now? This isn’t right.

  • FinnestraFinnestra Posts: 4 ✭✭
    #4530 December, 2020, 05:50 am.

    @KATclaw13 has the solution! Thank you so much! That finally fixed it for me. I agree with @tennbelle the glitch has something to do with purchasing gold. I was able to claim the free gifts until the Adversaries event where I purchased gold to buy one of the bundles and I was unable to, and haven't been able to purchase anything since (or claim the free gifts) but that fixed it for me. Hopefully, this can be resolved soon because the solution really is not obvious at all.

  • MumHigglebeeMumHigglebee Posts: 2 ✭✭
    #4730 December, 2020, 10:22 am.

    Why can’t you at least credit us with the complimentary gift? This is highly unfair. Especially to those of us who have spent hundreds of dollars on the game and now cannot fully participate. This is beyond frustrating. This is the third event now where I cannot purchase the special trunks, extra potions, extra keys, or even rent a cauldron.

  • RhiasiRhiasi Posts: 6 ✭✭
    #4830 December, 2020, 12:36 pm.

    Thanks to everyone posting possible work-arounds. Unfortunately none of them have fixed the issue for me.


    My question is WHY can’t support help us anymore? For the last two events, they were able to manually credit my free gifts and help me make a purchase with the coin that I already had. This time, the “Remy” bot directed me here.


    When you do get this fixed and credit us some sort of compensation, it is my hope that the package will contain multiples of edible dark marks, potent exstimulo potions, tonics for trace detection, silver keys, and about 200 energy. That should cover the special packages that I have not been able to purchase for the past three events since I could not purchase additional coins, or use my rental cauldron to keep on top of potions. Thank heavens I had amassed a healthy supply of potions prior to this issue!

  • MarkosusMarkosus Posts: 18 ✭✭
    #4930 December, 2020, 03:56 pm.

    @Rhiasi Have you tried the Apple Support contact route I described in a post two above your post?

  • cayliemacole91cayliemacole91 Posts: 2 ✭✭
    #5030 December, 2020, 04:00 pm.

    This is ridiculous! This is not a new issue - this has been going on for WEEKS and just now you’re acting like it’s a big deal. You obviously have lost a lot of iOS players money over this for you to finally care.

  • MarkosusMarkosus Posts: 18 ✭✭
    #5130 December, 2020, 05:44 pm.

    @cayliemacole91 Not sure if you are responding to my post of the fix via Apple Support, but to be sure, I do not work for WB, Portkey Games or Niantic. I am just a Wizards Unite player like you.

  • Jenv45Jenv45 Posts: 6 ✭✭
    #5230 December, 2020, 07:20 pm.

    I used the suggestion by @KATclaw13 and that worked but unlike @Antique100 , I cannot purchase gold at all. Now I get a message after enter my Apple ID and password that says “This has already been purchased - your purchase will be restored” except nothing happens. This is just soooooo frustrating!!!

  • Badsville423Badsville423 Posts: 24 ✭✭
    #5331 December, 2020, 07:45 am.

    This has been an issue for me since September, they haven’t given me any indication in 4 months that they have been able replicate or resolve the issue. It’s just NOW that they are openly acknowledging it as a known problem because it’s gotten worse.

  • AmyPrinceAmyPrince Posts: 3 ✭✭
    #5431 December, 2020, 03:59 pm.

    Still having this issue.... deleted the app and downloaded it again no help, downloaded assets no help, able to finish a potion then tried to claim my gift nothing, can not make a purchase. You would think they would fix this ASAP since it has potential to affect their income coming in. Especially if it has expanded to other iOS users recently like myself. I’ve had this issue since the dark mark event.

  • CassasauresrexCassasauresrex Posts: 41 ✭✭
    #5601 January, 2021, 04:30 am.

    I have never linked my Apple ID to the game and I ha e still been having purchasing issues since November. I have tried the steps mentioned above, including contacting apple support and there appeared to be no issues they could find and recommend I reach out to the app developers, and we all know what good that is doing.

    thanks for posting instructions for several ways to fix the issue! I’m glad there are fellow players doing what they can to help everyone out!

  • LeightaLeighta Posts: 11 ✭✭
    #5701 January, 2021, 04:45 am.

    After having to contact Support for Every! Little! Purchase! (from the gold I already had) I have been informed that they cannot allow me to purchase more gold because they cannot convert real currency into gold... It was "helpfully" suggested that I collect energy and ingredients the manual way (i.e. walking, etc) but I live in WA where our Stay-At-Home Order is still in effect and taken very seriously so that's not possible. (For example: even though my grocery store is only a mile away, I have managed to be pulled over TWICE in the last month by police to ensure I am on "legitimate and necessary" business).

    I am very pissed. I just want to spend my money, play the game and collect my rewards. Before this Niantic has been rather quick to fix bugs, but I've been having issues since before Thanksgiving (which was 11/26). It's been a month. F--- The What.

  • Spitti1Spitti1 Posts: 6 ✭✭
    #5801 January, 2021, 09:17 am.

    @KATclaw13

    thank you this has worked for me. I wish I would have seen this sooner I missed out in so much. Happy New Years and thank you again.

  • AviehendaAviehenda Posts: 4 ✭✭
    #5901 January, 2021, 10:39 am.

    Whoever you have hired to do your beta tests needs to be fired. And you need to hire me. Your interfaces don’t work and your releases are sub par. I have lots of ideas. You have my contact info. You can be better.

  • HermyLillyHermyLilly Posts: 3 ✭✭
    #6001 January, 2021, 07:30 pm.

    Here are some tips that have helped some users with this issue until Niantic can resolve the problem:


    Tips to purchase if you are getting the “Purchased Failed” on iPhone.

    Here is a temporary work around: Close down WU and follow steps below.

    Option 1). Go into iPhone settings -> your name -> Media and Purchases -> sign out. See picture below. Once you have signed out, open WU again, claim your gift or make purchases. If you sign back in to make purchases for other apps and games, you will need to sign out again for WU purchases.

    Option 2) You can also sign out of your Apple ID in the iTunes Store app. Once you have signed out, open WU again, claim your gift or make purchases. If you sign back in to make purchases for other apps and games, you will need to sign out again for WU purchases.

    Option 3) Log into WU using an iPad/tablet, old iPhone or Android phone and make your purchases/claim gifts.

    Option 4) You can also sign out of your Apple ID on your phone completely but that makes you reset everything by doing that. (So do this as last resort only.

    )

  • TheAmandaJaneTheAmandaJane Posts: 1
    #6102 January, 2021, 09:00 am.

    I am still not able to purchase anything!! I was never offered a fix or a complimentary bundle.

Sign In or Register to comment.