Daily Assignments - I often have to view my daily tasks in order to receive credit for them

KeybounceKeybounce Posts: 474 ✭✭✭
edited November 2020 in Report a Bug #1 latest comment 02 September, 2021, 03:30 pm.


I do not know what triggers this.

On any day, if you check the list of daily activities before you start any of them, they award just fine.

On most days, I can get my daily activities awarded just fine if I do them (pick things off the map, finish brewing a potion, etc) without checking the list.

** On some days, when I just start playing without rechecking that list that never varies from day to day, I do not get credit for my activities. **

iPhone 13, ios 13, no clue about game version but it does not yet have walking sync.

Visual info:

If you show/tell/teach me how to take a picture like that on my iphone, I'll happily share it with you. But as that image is taller than my screen, I don't even know where to begin (best I can do is snap a screenshot of a moving target and hope I got it.)


Tasks, Daily.

(I can't enter those into the actual tags field. Why not?)

Post edited by HPWUblue on
43 votes

Ongoing · Last Updated

An error affecting task reset causes this bug. Visit your daily assignments each day.



  • NoNoopsNoNoops Posts: 0 ✭✭
    #224 January, 2020, 12:48 pm.

    When playing for the last days the counters for the special assignment progress gets pegged but not the daily ones until you restart the app?

  • HPWUrobertHPWUrobert Posts: 717 admin
    #329 January, 2020, 09:31 pm.

    thanks for reporting @Keybounce

  • CimaresCimares Posts: 6 ✭✭
    #430 January, 2020, 08:05 am.

    Had the same problem this morning. Picked up some herbs, brewed a potion and returned about 6 foundables. Then went into the daily tasks and none had registered. Went out, returned a foundable and it was registered.

    The app had shown all the loading screens on start, although I hadn’t closed the app using iPhone swipe up.

  • TerraFriminatorTerraFriminator Posts: 2 ✭✭
    #501 February, 2020, 01:00 am.

    Same problem happened to me again today. I brewed a potion, used a potion, caught several foundabkes, and walked. And even though Adventure Sync is on as well, ALL categories, including walking distance, show zero progress for today.

  • TerraFriminatorTerraFriminator Posts: 2 ✭✭
    #601 February, 2020, 01:05 am.

    Since this was requested: restarting the app does NOT refresh the list with tasks that were performed that day.

  • KeybounceKeybounce Posts: 474 ✭✭✭
    #701 February, 2020, 03:27 am.

    Agreed; restarting doesn't help. I just have to do these things again.

  • HPWUrobertHPWUrobert Posts: 717 admin
    #801 February, 2020, 03:46 am.

    Thanks for the feedback on troubleshooting. Restarting is to refresh the tasks from the previous day as they're supposed to reset daily. Restarting won't retroactively give credit, my apologies @TerraFriminator @Keybounce

  • CimaresCimares Posts: 6 ✭✭
    #901 February, 2020, 07:41 am.

    Just an update as I had this happen yesterday again. This morning I picked up an ingredient, then waited for the daily award screen to show.

    once that had shown and credited me the daily gift, I picked up another ingredient and immediately got awarded the daily gift. Might be coincidence so will keep testing

  • MichelleShanMichelleShan Posts: 0
    #1001 February, 2020, 02:09 pm.

    Today and on a few occasions previously, when I open Harry Potter Wizards Unite and return a foundable or brew a potion that completed overnight, my daily assignments don't register that I've completed the task. It's very frustrating because I then have to restart the game and wait for another potion to brew which can be time consuming.

  • Yohanes12Yohanes12 Posts: 324 ✭✭✭
    #1101 February, 2020, 02:41 pm.

    @MichelleShan Have you restart you device? If you haven't please restart you device and you can use normal now.

  • AcumenAcumen Posts: 1,102 ✭✭✭✭✭
    #1201 February, 2020, 04:48 pm.

    This is a weird one that comes and goes. For the last several months, I've made it a habit to navigate straight to the Daily Assignments screen immediately after launching the game on a new day. By simply viewing the screen with all the daily tasks and closing it, that results in all relevant activity counting as it should. Should you have to do this? Well, no. It should just work like it's supposed to as soon as the clock strikes midnight on a new day, without having to restart the application or open the Daily Assignments screen. However, this bug has been around since the game first launched. It'll go away with one update, then reappear with the next. That being the case, opening the Daily Assignments screen first thing is the best way to avoid frustration.

  • CimaresCimares Posts: 6 ✭✭
    #1306 February, 2020, 07:51 am.

    another instance this morning, picked up my brewed potions on opening the app, then the daily gift screen showed.

    no credit given for the potion against daily tasks.

  • Alcesalcea15Alcesalcea15 Posts: 2
    #1410 February, 2020, 01:33 pm.

    Brewed multiple potions and used multiple no credit. High foundables returned credited for event rewards not dailies. Picked up a ingredient of the map credited properly. Adventure sync working daily walking reward half done.

  • Alcesalcea15Alcesalcea15 Posts: 2
    #1510 February, 2020, 01:38 pm.
  • MorrgLeFayMorrgLeFay Posts: 47 ✭✭
    #1613 February, 2020, 03:22 pm.

    Similar issue. I picked up an ingredient but had NOT selected the “complete” button to receive award. Left the game, when I cane back, task and award showed as completed, but my amount of spell energy had not changed (award wasn’t actually awarded).

  • SaisonRueSaisonRue Posts: 1
    #1718 February, 2020, 11:48 pm.

    This has also happened to me several times over the last few weeks. I do some (but not all) tasks in the morning, collect the reward, then later that afternoon the progress has reset. Restarting the app does not help, as everything has already reset. I am using iPhone 11, latest iOS and app version.

  • OndrashekOndrashek Posts: 0
    #1820 February, 2020, 06:23 am.

    If I left app in multitasking over night and I start on tomorrow, it do an app restart and if I do something from daily assignment (brew potion, ingredient from map ...) it won't count as completed.

    iPhone 11 Pro

    iOS: 13.3.1

    App: 2.10.0 and earlier

  • KatDanversKatDanvers Posts: 3 ✭✭
    #1921 February, 2020, 07:57 pm.

    This happened to me today too. Nothing registered on the daily challenge page despite completing all the activities.

  • kitty1208kitty1208 Posts: 3
    #2024 February, 2020, 01:52 pm.

    Hello i have tried on 3 different android phones that are compadable with wizards unite to do a wizard challenge and all 3 cells say net work error but my sister who has the same phone as one of the devices can do them no issues it happens as soon as i click a level to add a rune stone

  • VercynVercyn Posts: 2
    #2125 February, 2020, 04:15 pm.

    Today again I have not gotten credit towards my daily tasks for completing a wizarding challenge. This has happened a few times now- any suggestions?

  • LadymuckLadymuck Posts: 2
    edited February 2020 #2229 February, 2020, 12:11 am.

    This has also happened to me.

    I collect items, get my 10 foundables etc, all daily requirements. Sometimes it appears as a notification, but when I go to collect my daily tasks are set to zero as though I have done nothing.  Doesnt help resetting. I have android s10

  • AlThor77AlThor77 Posts: 0 ✭✭
    #2304 March, 2020, 09:23 pm.

    Spend all day doing daily tasks and they dont register. Happens more than I'd like to admit. Seems like I'm wasting my time.

  • whawk640whawk640 Posts: 1 ✭✭
    #2404 March, 2020, 11:25 pm.

    I've seen that as well. I found if I go click in the daily task list before I start picking up ingredients or catching foundables, I start getting credit.

  • kiheikidkiheikid Posts: 2,168 ✭✭✭✭✭
    #2505 March, 2020, 03:35 am.

    thanks to all these reports, i know to “check in at the front desk” —— that is, go first to the task list, whether daily assignment or special event, before actually doing what is on the task list, to prevent getting ripped off as to getting credit. it has become somewhat of a habit by now. and for special events, i know to restart my phone or at least my app, and then “check in” at the task list, before starting.

  • Lexicon0208Lexicon0208 Posts: 0
    #2617 March, 2020, 05:49 pm.

    Often potions aren't counting, but recently many of them aren't registering. Today none of them are counting.

    Yes I've tried restarting my phone.

  • HPWUblueHPWUblue Posts: 1,709 mod
    edited March 2020 #2717 March, 2020, 07:11 pm.

    Hi @Lexicon0208, welcome to the Community! We're investigating an issue where the Daily Assignments don't reset from the previous day until you restart the app and visit its page.

    I checked your account to see when they got reset, and it has happened very recently. If you do the tasks now, they should start registering towards Daily Assignments. Also, the Potions will only count when you collect them from the Cauldron (queuing them to brewing process won't count towards the task).

    As a workaround, while we continue to investigate this issue, please restart the app and visit the Daily Assignments page before you begin your gameplay.

    PS: To make it easier for others to find your post, I've moved it to a related discussion. Good day!

  • PhreighnQPhreighnQ Posts: 3 ✭✭
    #2817 March, 2020, 07:27 pm.

    I had this happen again today. I completed the bonus tasks for the event, but nothing counted towards my daily tasks. This bug has caused me to lose the gold rewards for completing the daily tasks for days like today when I only have one time that day when I will be out of the house. I have probably lost that gold 8 to 10 times all because the game can't figure out what day it is.

  • AryaWyzeAryaWyze Posts: 0 ✭✭
    #2925 March, 2020, 02:50 pm.

    No results for When I sign on each day immediately get my daily reward. If keep playing don’t credit for tasks unless close the app and in again. reported it last year it’s still happening to me. Anyone else?.

  • SlowScoobySlowScooby Posts: 3 ✭✭
    #3030 March, 2020, 01:46 pm.

    I am seeing the same thing

  • KeybounceKeybounce Posts: 474 ✭✭✭
    #3106 April, 2020, 08:58 am.

    So with the current version of the game, it has changed from "sometimes" to "always".

    I always have to "check in" and see the list of tasks before anything I do will get credited.

    Restarting doesn't seem to help. I have to actually view the task list.

    The only difference from when I first reported this is that it is now constant, no exception.

    Current version is, but I'm pretty sure the "always" was also valid before I got the item pickup annoyance screen as well.

    Note that the "New day's login reward" is awarded just fine as soon as the clock moves to the next day and I start playing.

    As a quick-and-simple fix, can the "you earned something new for playing today" award also trigger the "visit the task list" reset?

Sign In or Register to comment.