Adventure sync background data not working on iOS

mever1ckmever1ck Posts: 12 ✭✭
edited July 31 in Report a Bug #1 latest comment 21 September, 2020, 06:51 pm.

Adventure sync background data not working on iOS, I need to always reinstall the game to fix it. Two iphones SE on iOS 13.5.1, two accounts, same problem since last week. First picture repeats every few minutes, second picture is privacy health with missing setting for HPWU. More people confirmed same problem on reddit

Post edited by HPWUrobert on
9 votes

Investigating · Last Updated

This issue has been shared with the team for further investigation


  • 42RandomDent42RandomDent Posts: 8 ✭✭
    #221 July, 2020, 04:46 pm.

    I am having this exact same problem on my new iPhone SE and old iPhone 8, both running current iOS

    Pokemon Go is also affected, but it's much more annoying in HPWU as I have to re-download all assets and re-clear all the red dots every time I re-install the app. Pokemon is much easier to re-install.

  • HPWUrobertHPWUrobert Posts: 710 admin
    #321 July, 2020, 05:02 pm.

    This data menu is meant to be blank. The HPWU app does not work like Strava and records your fitness history. The notification will pop up if Adventure Sync wasn't set up properly, the game doesn't detect your location services (problem with your internet connection and GPS), or you've allowed your phone to use a low power mode.

  • 42RandomDent42RandomDent Posts: 8 ✭✭
    edited July 21 #421 July, 2020, 07:24 pm.

    @HPWUrobert No, it's not meant to be blank, it's meant to have toggle switches to turn different settings on and off.

    Here's a screenshot of what it usually looks like when adventure sync is working properly. Once the alert shown in the first screenshot in the main post comes up, it switches to looking like the blank one posted above.

    Adventure sync is switching off, and the data menu is looking blank, every few days. I am absolutely not changing any other settings, it keeps happening spontaneously. I delete and reinstall the app, set up adventure sync again, it works OK for a few days, then it happens all over again. I had used HPWU and PoGo since day one without having this problem; it is a new bug.

  • HPWUrobertHPWUrobert Posts: 710 admin
    edited July 21 #521 July, 2020, 07:35 pm.

    @42RandomDent thanks for the info.

    I took a look at your account, and see that the only time Adventure Sync was disabled was when you reinstalled the app. So the notification can be firing because it doesn't detect location services on your phone.

  • 42RandomDent42RandomDent Posts: 8 ✭✭
    edited July 21 #621 July, 2020, 07:50 pm.

    @HPWUrobert Thanks! There must be some kind of disconnect somewhere in the settings, or in how HPWU/PoGo talk to the Health app or something else in the iOS, as I have had the "adventure sync disabled" pop-up multiple times in HPWU and also Pokemon Go over the last few weeks. When that happens while I'm out without WiFi and can't immediately delete and re-install, the games definitely don't register my distance walked. So... my app thinks adventure sync has been disconnected but then won't re-connect it (I get the blank screen if I try to reconnect Adventure Sync without deleting and reinstalling), but that isn't showing up in my account?

    Location services glitches would seem like a likely explanation if this had been happening all along, but it's the fact that it's a new phenomenon after a year of glitch-free HPWU play and 3 years of glitch-free PoGo play that's making me a bit skeptical!

  • Chatham25Chatham25 Posts: 1
    #722 July, 2020, 03:26 am.

    Since the update, I haven’t been able to get credit for the .25K distance, yet I’ve had multiple portkeys opened. Prior to update, my adventure sync seemed fine. I opened portkeys and gotten the .25k reward. I checked my settings and the app has full permissions for health and location.

  • mever1ckmever1ck Posts: 12 ✭✭
    #822 July, 2020, 06:09 am.


    Hello, it is exactly as @42RandomDent said page should not be blank and it is not after reinstall. We (my and my wife) have this same problem almost every day (2 days per account) and we cant re download app + all assets outside of wifi as this will **** our dataplans. Without reinstall we cant even play due to pop-up window which we are not able to dissable. Settings will not let us to turn AS completly off. Only fix is to delete reinstall (redownload assets, did settings again and clear all red dots). Please take a look at this as this probably affects way more iOS users than we 3 in this thread. Some others reported this on reddit also.

  • mever1ckmever1ck Posts: 12 ✭✭
    edited July 22 #922 July, 2020, 12:14 pm.


    My wife currently have this problem on her account, her name in game is fogiiinka. If you can, check her account now. I have also video for you if you need.

    Post edited by mever1ck on
  • mever1ckmever1ck Posts: 12 ✭✭
    #1028 July, 2020, 06:50 am.

    @HPWUrobert any news, we need to reinstall and re-download all assets cca every 2 days.

  • HPWUrobertHPWUrobert Posts: 710 admin
    #1128 July, 2020, 06:01 pm.

    @mever1ck I want to see if the AS notification is popping up in error. Can you tap Maybe Later the next time you get the prompt, wait a day, then tag me again. Thank you.

  • mever1ckmever1ck Posts: 12 ✭✭
    edited July 29 #1229 July, 2020, 05:23 am.

    @HPWUrobert Hello, My wife (fogiiinka) just have this issue again. When I press MAYBE LATER I need to select GO BACK / DENY. GO BACK brings me to MAYBE LATER / ENABLE. So I need to select DENY, which ends on SYNC DENIED-OK. After that there was obligatory bug with "Connection ost. Check your wifi or mobile data". But now MAYBE LATER-DENY-OK needs to be done after every catch of foundable. So please take a look asap because it is literally unplayable like this.

  • 42RandomDent42RandomDent Posts: 8 ✭✭
    #1329 July, 2020, 04:46 pm.

    @HPWUrobert @mever1ck same issue here. I've tried hitting Maybe Later when this problem has happened before, and it just keeps coming back over and over again until you delete and reinstall the app

  • mever1ckmever1ck Posts: 12 ✭✭
    edited July 30 #1430 July, 2020, 05:40 am.

    @HPWUrobert Any news? It is 24h since problem occurred on her account, she did not reinstall to fix it this time. AS disabled itself in settings after full day of MAYBE LATER-DENY-OK.

    Post edited by mever1ck on
  • 42RandomDent42RandomDent Posts: 8 ✭✭
    #1530 July, 2020, 05:45 pm.

    @HPWUrobert I don't know if this helps, but I just got the AS pop-up again. I decided to try something different so I hit Maybe Later, logged out, then logged back in. AS was still off; when I tried to re-enable it from the in-game settings, it told me I needed to manually set the fitness permissions from the iOS settings. So I went to my privacy->health app settings, clicked HPWU, and once again it was completely blank instead of having the usual multiple toggle switches for various settings.

    Deleted and re-installed the app and am now re-downloading all assets YET AGAIN as I type this.

  • HPWUrobertHPWUrobert Posts: 710 admin
    #1630 July, 2020, 07:37 pm.

    thanks for updating me. I've updated my bug report for the team. sounds like the only workaround (fix) is to reinstall. unfortunately we can't manually fix the issue if it's continually happening.

  • 42RandomDent42RandomDent Posts: 8 ✭✭
    #1730 July, 2020, 09:20 pm.

    Thanks for passing it on, hope they find a fix soon!

  • mever1ckmever1ck Posts: 12 ✭✭
    #1831 July, 2020, 07:14 am.

    @HPWUrobert Thx, we will hope in soon fix. Will you please add that to known issues list so nobody will forget this?

  • 42RandomDent42RandomDent Posts: 8 ✭✭
    #1912 September, 2020, 07:33 pm.

    @HPWUrobert Hi, I just wanted to update with some new info that I hope will be helpful. This error is still happening, but less often - about every 10-14 days instead of every 2-3 days. Meanwhile, the problem seems to have gone away completely in Pokemon Go, where my AS hasn't randomly turned off for at least a month (although I probably just jinxed it). So, if the dev team has been trying to fix this, they are on the right path, but it is still a problem!

  • QwertybytesQwertybytes Posts: 1
    #2021 September, 2020, 06:51 pm.

    I am also having the issue described above except Pokemon Go does not seem affected.

    The problem has persisted despite updating to app version 2.15 on iOS 13 and 14.

Sign In or Register to comment.