Device incompatible error

ShedaimShedaim Posts: 3
in General Questions #1 latest comment 05 July, 2019, 12:11 pm.

Hi,


I'm playing the game on a Samsung Galaxy s8 with latest updates.

Downloaded the game from Play Store.

The game tends to crash with a "device incompatible" error. It sometimes happens on startup, sometime after a few minutes and other times it may run for even half an hour. Tendency of the crashes tends to be around 50% of startups and about 75% it crashes after no more than 5 minutes.

This is of course very annoying and makes the game unplayable, as it destroys wizarding challenges (Taking up time to restart the game) and portkeys advance.


Would appreciate some help on the matter.

Thank you very much

Reply

Answers

  • WerewolfChaserWerewolfChaser Posts: 512 ✭✭✭✭
    #204 July, 2019, 03:25 am.

    Is your phone rooted?

  • ShedaimShedaim Posts: 3
    #304 July, 2019, 11:17 am.

    No, not rooted

  • SIRlUSBLACKSIRlUSBLACK Posts: 29 ✭✭
    #404 July, 2019, 06:58 pm.

    Have you tried downloading the games from Samsung store?

    I heard a few of my friends stating downloading from Samsung Store resolved the issue!

  • ShedaimShedaim Posts: 3
    edited July 2019 #505 July, 2019, 12:11 pm.

    I tried a bunch of stuff without success. Deleted "Work" profile, changed Battery saver configurations, modified permissions, disabled/enabled Game Center.

    At last I decided to Factory reset my device, as it was obvious it really was a device issue, now it works without any problems.

    Although my phone was not rooted, I did have some applications installed (from some past experiments) like Magisk and a non-official app store. I'm not sure these apps would have made the game think the device was rooted and I only thought about it after Factory Reset, so I didn't manage to test uninstalling them.

    Thank you guys,

Sign In or Register to comment.