The Dreaded Red Dot Of Annoyance

KonadaKonada Posts: 10 ✭✭
in Feature Requests #1 latest comment 31 October, 2019, 10:12 pm.

 I have a Samsung Galaxy S9+ and the new update (2.3)  is giving me the Red Dot of Annoyance on my Profession page (Magizoologist). It Is on the Suitcase Page on the Profession circle icon; on the Main Lesson Page down on the lower left corner Lessons area (vs Expertise area); and on the Page that lists the “”Full”” Lessons (the one that shows Foundational Magizoologist and More Lessons Coming Soon) The Red Dot seems to be telling me I have not finished the First Full Lesson (I only have 103/142)


Yes I have clicked on every single class circle, not one of the classes has a Red Dot (only low on the full page) and I do not have enough of any combination of Red Books/Scrolls/Green Books to advance any of the classes.


Thank you for your time and assistance in this matter.

Reply

Comments

  • ZookiTabookiZookiTabooki Posts: 637 ✭✭✭✭✭
    #224 August, 2019, 02:54 pm.

    Sounds like we should get together and go bowling...

    https://community.harrypotterwizardsunite.com/en/discussion/2475/red-dot-is-back

    Here we go again.

  • AcumenAcumen Posts: 1,102 ✭✭✭✭✭
    #324 August, 2019, 04:13 pm.

    I noticed this immediately after they fixed the permanent red dot on the suitcase due to a persistent notification on the books pages of the challenge registry. Some folks had perma-dot on achievements, as well. This one doesn't annoy me as much. As long as there are no permanent red dots on my suitcase, I'm not complaining. The good news is, at least the red dots seem to make sense on the profession tree now. At first, they were scattered all over that page. Now I only have red dots on the modules where I currently have enough books/scrolls to master the next lesson.

  • DigitalisDigitalis Posts: 189 ✭✭✭
    edited August 2019 #424 August, 2019, 06:43 pm.

    also having the same issue

    i like how it worked just recently before the update, where once you opened the book to expand the skill tree it would remove the red dot from the professions icon in the suitcase menu.


    that is all needs be done again to make this be fixed - the individual red dots on the skills themselves matter not, as long as the one on the profession icon in the suitcase menu can be cleared.


    the red dot system is compromised completely with the unclearable red dot on the profession icon in the suitcase menu, simply allowing it to clear when skill tree is expanded is enough to fix.


    i definitely am not trying to spend the few precious books i have been saving for a skill near the end of the tree on what they 'could' be spent on now, and as long as i have the resources to spend on a lower skill now the dot persists.


    i really like the dot notification system. it is incredibly helpful in game and indispensible when it works.


    thanks!


    edit: moto zforce2 device, android version 9.

  • AcumenAcumen Posts: 1,102 ✭✭✭✭✭
    #524 August, 2019, 06:58 pm.

    Ah, what you're experiencing sounds MUCH more annoying @Digitalis. I don't have a persistent red dot on the profession button in the suitcase. I only have red dots on the modules with lessons I could master with my current inventory of scrolls/books. The dots don't clear, but I don't mind very much since they only show up on the lesson tree and nowhere else. Like you, I'm doing the lessons that require the most books, and working my way back. That approach seems best. When I see other people using the same strategy, it makes me feel validated as a wise, old wizard. 😁

  • DigitalisDigitalis Posts: 189 ✭✭✭
    edited August 2019 #624 August, 2019, 07:05 pm.

    @acumen totally agree, and ditto on the confirmation of tactic back at ya. tackling the hardest things first is slower up front, but gets easier as time goes on. playing the long haul.

    salute!

  • DigitalisDigitalis Posts: 189 ✭✭✭
    #724 August, 2019, 10:01 pm.

    ...and, it's gone.

    was bugged since last night until now, i dont know what fixed it but no longer does the profession button in the suitcase menu have the unclearable red dot.

    weird, but, am very thankful that for whatever reason it fixed itself. i had tried everything short of uninstalling/reinstalling to make it work.

  • AcumenAcumen Posts: 1,102 ✭✭✭✭✭
    #824 August, 2019, 10:13 pm.

    Nice!

  • DigitalisDigitalis Posts: 189 ✭✭✭
    #925 August, 2019, 03:18 pm.

    spoke too soon. is back as described. i dont know what made it vanish for the two hours yesterday, but the dot is back and wont clear on the profession tab in the suitcase menu if i have the skill tree resources to do something.

    i still have nine restricted books carried over from the first half of the brilliant back to hogwarts event. when second half ends i will still have nine restricted books - maxed my hexes at 4 books per, and all the other things i want are 15 restricted books.

    the bat bogey hex upgrade, useless as it is, takes 4 restricted books and 7 scrolls to do. i will perpetually have 4+ restricted books until my primary profession is done with the 15 restricted book skills, and having less then seven scrolls is a state of existence i may never see again.

    (maxed the zoo profession skill tree can be done without spending books of any kind, only scrolls, and in 3 more skill levels can say the same for professor. once that is done, i am not spending restricted or regular books on a secondary profession until my primary is complete - so scrolls will start piling up pretty hardcore)

    this means, basically, that red dot on my profession button in the suitcase menu will never, ever clear and the whole red dot system at that point is useless on the game map since the suitcase button will always have the red dot.

    definitely think i liked it better when you could clear the red dot on the profession button in the suitcase menu by simply expanding the skill tree. that way i could still be alerted when a potion finishes brewing, or a registry family was ready to rank, or a portkey was done.

    (it doesnt always throw the portkey ready to open purple screen for me, its missed doing that i think 5 times now, and with the red dot bugged have walked well more then 2km with no key turning in a lock because i did not manually check.)

  • AcumenAcumen Posts: 1,102 ✭✭✭✭✭
    #1025 August, 2019, 05:33 pm.

    Lame! That would definitely annoy me. Few things bother me more than being unable to clear notifications anywhere in the system settings or apps installed on my device. It even bothers me to see unacknowledged notifications on other people's devices, lol.

  • Grace1351Grace1351 Posts: 1 ✭✭
    #1129 August, 2019, 02:53 pm.

    I have a Samsung S10+. I have a red Dot on my suitcase and lessons, even though I don't have enough resources to do anything. I'm lacking either books or scrolls on all of them. There is no dots on any of the individual lessons. This is an issue since I don't know until I open the suitcase what it wants to notify me about. Sometimes it even has a dot on the individual lessons even though I don't have enough of something to complete it. I agree that I would be okay if the dot would go away when the tree was opened.

  • LeahAFreeElfLeahAFreeElf Posts: 1 ✭✭
    #1208 September, 2019, 10:01 pm.

    Has there been any conclusion about this? I have an iPhone x and constantly have the red Dot on my suitcase. I've gone in every single unlocked class in my profession to see if there are any I have completed that I can. Nothing.

    The only thing I can do to make it go away is hope for an actual available class. But once I do the class and it goes away briefly, it's back the next time I play. Ugghhh

  • TallHRLadyTallHRLady Posts: 1
    #1322 September, 2019, 01:40 pm.

    Hi! I’m still experiencing the red dot as described by LeahAFreeElf. I progressed down my magi profession tree skipping certain lessons to get to the bottom. I specifically skipped Forum Quorum which requires 6 scrolls & 15 green books. I haven’t had 15 green books in a while...but often have 6 or more scrolls.

    My theory: I think the game only considers collected scroll count (not red or green book count) against available lessons when putting a red dot on my suitcase & profession icon. Within the lesson tree no red dots appear on any available lessons (since I don’t have enough red or green books).

    Please fix!

  • SmithelpuffSmithelpuff Posts: 8 ✭✭
    #1422 September, 2019, 08:58 pm.

    Mine goes away if I click into ALL of the lessons that I could take and then exit them. So now even though I have those lessons with dots on them, the main screen profession circle does not. Still... royal pain... I am a distracted by the red dot... ahhh.

  • SuperSteavySuperSteavy Posts: 1
    #1517 October, 2019, 02:28 am.

    The red dot of annoyance is still around. Any fixes yet?

  • MacBeth13MacBeth13 Posts: 1
    #1631 October, 2019, 10:12 pm.

    The red dot of annoyance is still haunting me, is there seriously still no solution for this problem?! Hopefully there will be a fix soon!

Sign In or Register to comment.