Troubles on home wifi network only

Subject6Subject6 Posts: 33 ✭✭
in General Questions #1 latest comment 23 November, 2021, 05:58 pm.

There is a greenhouse right across the street from where I live, so I used to harvest it fairly often. However, for about the past month I have gotten the "You've lost connection" error message every single time I have tried to harvest it. This only happens at my house, where I have a very strong, stable, and reliable connection. This does not happen at my church or on my college campus - another two places where I am always connected to wifi with a strong, stable, and reliable connection. Is anybody else having this problem or does anyone know of a solution? @HPWUblue

Reply

Comments

  • DjeaDjea Posts: 367 ✭✭✭
    #220 November, 2021, 07:11 pm.

    I have the same problem when I try to get something close to home. Have you tried turning off your Wi-Fi connection and rely only on your phone network? I do that during Lethal Adversaries Events so I don't loose any Lethals. It helps with my connectivity issues.

  • Subject6Subject6 Posts: 33 ✭✭
    #320 November, 2021, 08:00 pm.

    @Djea Yes, I have tried that. Unfortunately it doesn't fix the issue for me. Glad to hear it helps you, though.

  • KodokmagKodokmag Posts: 1,224 ✭✭✭✭✭
    #420 November, 2021, 08:24 pm.

    from my experience of playing real time online gaming there is internet provider that not good for playing, stable connection/strong signal not always give playable gaming. and eventou this game doesnt really like those massive multiplayer online game, but apparently it loos like its play as such. so try different ISP sometimes resolved the problem.

  • Subject6Subject6 Posts: 33 ✭✭
    #521 November, 2021, 09:46 pm.

    @Kodokmag Huh, that's interesting. It makes sense, though, so I can see how switching might help. Unfortunately we're locked in a contract and the only other ISP available in our area is notoriously worse for gaming anyway. I think the ISP at my church is the same, but I have no idea about my college campus. They're in a different county, so they very well may use a different one. That's good insight for future, though. Thank you for sharing your experience! I'll be paying attention to that.

  • HalloMamiHalloMami Posts: 191 ✭✭✭
    #622 November, 2021, 12:05 pm.

    I'm not sure it actually has anything to do with your network connection. At least not directly. When I'm at home I have a Inn nearby. Nearby here means, that more often than not I can visit the Inn from home, but I'm kind of at the edge of the distance at which I can reach it. Factoring in some normal GPS drift, it may happen that the game thinks I'm too far away.


    Now, there is something that my wife and I observe quite commonly (and it has been like that since the game release), that while yes, the avatar will move around somewhat and occasionally even a little bit more, in most instances it basically is displayed at our house, but spawns (ingredients, foundables, etc) appear at some distance. And we actually can interact with these foundables like you normally would do.


    So, it seems like part of the game thinks that we are at a remote place, but actually shows the avatar where we are. Now, while we can interact with the remote spawns as if we where standing there, we can't interact with POIs (e.g. Inns) there. Instead, our Inn will appear to register that we are close to it (like, it will get larger if we get close enough), but when we try to actually collect energy, we get the "network connection" error from the game.


    Now, I guess this part is functionally similar to PoGO: If you want to spin a pokestop but while doing so moved out of the range of it, you get a "network error" back; and the drift that we observe there is similar in direction to that that we see in HPWU (for some reason the drift seems to go more or less North or South of our actual position, no idea why). But in PoGO the Avatar and everything around it moves to that position, and there you can spin stops and catch mons that are at your incorrect position.


    For HPWU, the implementation seems to be different in that the Avatar and the GUI Inn representation seems to be according to one position and the spawns according to the other position. So, the GUI likely thinks we are at point A close to the Inn, tells the server that we want to collect energy, but the server thinks that we are at point B, too far from the Inn and responds with the network error message.


    I always wondered how this can happen, that the system can come to the conclusion that we at two points at the same time. I'm speculating now, but this really might have to do with Wifi after all: I think if you are in your home network, the navigation info might be derived from that. Like, e.g. Google noted at one point that when you are connected to Wifi XXX, your GPS is always roughly at y/z and then assigns the location of the Wifi to that point. Later, when an app asks for the position, it might get two answers: Based on the GPS in your device you should be at point A, but you are connected to this Wifi, which we happen to know is at point B. Take your pick.


    Never tested this hypothesis, though, but what remains are clear indications that for some reason the game internally works with two different positions, and you can get the "network error" message if they don't agree...

  • HalloMamiHalloMami Posts: 191 ✭✭✭
    #722 November, 2021, 09:41 pm.

    Uhm, second try at a post now...


    I don't think that this has to do anything with Wifi, at least not in the sense of a bad connection.


    Looking at the behavior of the game when we sit at home it seems like HPWU is using two different sources to determine relevant positions. One of those is where the Avatar is placed, and that seems to be used when the GUI judges whether you can open an Inn or Fortress (the POI then is shown larger). The other is where you see spawns popping up.


    Normally, these two points coincide, but when we are at home, we quite frequently have the case where the foundables/ingredients pop up in a circle, but the Avatar is not in the center of that circle, but at its edge. In cases of strong GPS drift, we see foundables popping several hundred meters away while the avatar stays at the position of our couch.


    Now, we can always interact with foundables/ingredients that we see, regardless of how far they are away. However, we can not interact with those remote Inns (they don't get larger). However, we have an Inn near to our place; what we see is that when the spawns are at some distance, but our Avatar is displayed close enough to our Inn (so that it does get larger), we can get into the Inn, but when we try to do anything in there, we get the "network error" message.


    If I have to speculate on how this works at all: E.g. Google determines the positions of Wifis based on positional information of smartphones that see this wifi. In turn, it can use the info of what (known) wifi network your smartphone sees to position the phone. I kind of have the suspicion that the app uses this information to determine the position of the avatar and if it should mark e.g. Inns as interactable (make them large); the server, however, uses the position of the GPS (which may or may not agree to well with the position of the wifi) to display the foundables.


    Either way, it seems like when the app tells the servers that the player wants to dine at Inn at point A, but the server thinks the player is actually at point B which is too far away to work with the Inn, you get the "network error" messge.


    I have no idea why it is implemented that way or if this is intentional...


    Btw, PoGO doesn't have the same behavior: Yes, we also tend to drift away from home at times (strange enough mostly either straight N or straight S), but in these cases we actually see our Avatar change its position. However, you can/could kind of get the same error message: When just at the edge of the interaction distance from a pokestop, enter the stop, move away and try to spin it, you also can get a "network error" message (or at least you could, this might have been changed recently to a less misleading error message).

  • Subject6Subject6 Posts: 33 ✭✭
    #822 November, 2021, 10:50 pm.

    @HalloMami Heck, that was a lot of information! Thank you! That definitely helps to clear things up a bit. I do notice a lot of drift when I'm at home, specifically to a field on the opposite of the greenhouse from where I live, so I can see how this would be the case. Thank you so much for taking the time to explain all that!

  • KodokmagKodokmag Posts: 1,224 ✭✭✭✭✭
    #923 November, 2021, 02:23 am.

    yes it is, i think that too low of GPS accuration also give the error. you can see it in blue circle of google map (the wider it is from you the lower the accuration).

    and wifi should give more accurate GPS location (instead of GPS device) while inside building. i think there is a way to register your wifi GPS location to google map/location, and in turn give your phone more accurate GPS location.

  • PsychicTardisPsychicTardis Posts: 25 ✭✭
    #1023 November, 2021, 03:43 am.

    One other idea to check, is if that POI (greenhouse) shows up in either of the other Niantic games. I've come across a greenhouse once that I couldn't interact with at all, and when I checked in in PoGo [back when I used to play] I found that the POI had actually been removed. It is a small possibility that if you have repeatedly tried interacting with that, and despite GPS drift etc. you weren't able to, the POI could be removed from the server without having been removed specifically from HPWU maps. Just my thoughts of another possibility.

  • Subject6Subject6 Posts: 33 ✭✭
    #1123 November, 2021, 05:58 pm.

    @PsychicTardis I guess that would make sense in a way. HPWU is the only Niantic game I play, so I can't really check that, unfortunately. Good thing to know about, though. And, by the way, I love your name.


    All, thank you so much for the responses and help! The greenhouse has been working just fine for the past few days, but sometimes the greenhouse icon just... disappears? It doesn't happen often, and usually restarting the app makes it show up again, but it is certainly strange. Hoping issues are nonexistent (or very minimal, at the very least) for you all!

Sign In or Register to comment.