iPhone X cannot open portkeys..

MagetusMagetus Posts: 25 ✭✭
in Report a Bug #1 latest comment 09 October, 2019, 10:34 pm.

I’ve searched high and low for camera access to WU in settings and everywhere else.. iPad Pro hasn’t no problems. What’s the deal?

Reply
Tagged:

Comments

  • ZookiTabookiZookiTabooki Posts: 477 ✭✭✭✭
    #225 July, 2019, 12:12 pm.

    My wife had issues opening Portkeys on her IP10 until she turned off AR. Temporary solution but it works.

  • DogoutlawDogoutlaw Posts: 1,242 ✭✭✭✭
    #325 July, 2019, 12:18 pm.

    Meaning you don’t know how to give WU access to your camera? Or you don’t know how to adjust camera settings within app?

  • MagetusMagetus Posts: 25 ✭✭
    #427 July, 2019, 06:51 am.

    Meaning I tried with ar on and off and there are zero additions inside the setting app for WU for my camera to be accepted nor inside my cameras settings.

  • DogoutlawDogoutlaw Posts: 1,242 ✭✭✭✭
    #527 July, 2019, 02:51 pm.

    Ok, if you can toggle AR in the game settings, it sounds like you’ve given access to your camera already. I know on my iPhone (7 not X), if I don’t give access to camera in phone settings, the AR toggle goes away altogether. So have you tried turning off AR, and then opening the portkey? To be honest I leave AR off all the time. Speeds up the traces, etc. I haven’t had any trouble with portkeys (knock on wood). If you have, I think you need to report it in app. Maybe just a glitch/bug on your phone... idk.

  • DogoutlawDogoutlaw Posts: 1,242 ✭✭✭✭
    #627 July, 2019, 05:12 pm.

    @HPWUMicah is there a known issue with portkeys on iPhone X? Maybe you can help with this one?

  • RineGilbertRineGilbert Posts: 8 ✭✭
    edited July 27 #727 July, 2019, 07:22 pm.

    I have the iPhone X and camera access is turned on. https://drive.google.com/file/d/1kSQ2T5IQ4BPvSrq2INYJbmhf7ahLpRw-/view?usp=drivesdk (I can’t seem to get the url of the screenshot to “insert” so, I pasted it here).

    Have you tried powering off your phone to reboot?

    In phone settings, scroll down to the Wizards Unite App. That will be where you allow camera access to the app.

  • HPWUcaseyHPWUcasey Posts: 95 admin
    #829 July, 2019, 08:30 pm.

    Hi folks, there have been a few issues with Portkey rewards, would love to get some more information on this one to see if it matches what we're currently working on resolving. @Magetus can you give me some more information about what happens when you try to open your Portkey?

    A current known issue is related to camera privacy settings for the app. Try these steps to ensure camera permissions are enabled.

    1. Make sure your camera privacy settings for Harry Potter: Wizards Unite is enabled by going to iOS Settings app > Privacy > Camera > and enabling Harry Potter: Wizards Unite.

    2. Then, enable camera permissions for Harry Potter: Wizards Unite

    • Go to the Settings app on your iOS device and scroll down to the list of apps.
    • Tap the Harry Potter: Wizards Unite app and you’ll see the permissions you can enable or disable. Enable the camera permissions.

    Let me know if that helps!

  • Andr0medussAndr0meduss Posts: 1
    edited August 17 #917 August, 2019, 07:15 am.

    Hi. Had this issue on new iPhone X. Wizards unite didn’t show under privacy settings. Camera was also not an option under settings for the app.

    Reinstalled the app, was prompted to give access to camera in the app, accepted, and now it works fine. Hope this helps if you ever get this issue.

  • FilurenFiluren Posts: 35 ✭✭
    #1018 August, 2019, 10:28 am.

    https://community.harrypotterwizardsunite.com/en/discussion/109/portkeys-dont-work#latest @HPWUcasey don't know if you've noticed, but there are quite a few of us who are having trouble with portkeys in general. And yes, I am starting to get a bit salty about this.

  • FilurenFiluren Posts: 35 ✭✭
    #1221 August, 2019, 07:48 pm.

    @HPWUMicah thank you for the update! Glad to hear it's getting attention and I do understand it has to be a complex problem, with all the different phones being affected.

    Then I'll throw some sugar at you and wish you good luck in solving this! 💕

  • JulieJubzJulieJubz Posts: 534 ✭✭✭✭
    #1321 August, 2019, 08:02 pm.

    @HPWUMicah also throwing some sugar at you, and wishing you guys luck! We know you guys work hard, and we're thankful for it 💕

  • HPWUcaseyHPWUcasey Posts: 95 admin
    #1422 August, 2019, 12:27 am.
  • CraeftCraeft Posts: 976 ✭✭✭✭✭
    #1522 August, 2019, 03:53 am.

    I don't have any sugar. How about some flour with a bit of Sriracha?

  • KingZogKingZog Posts: 16 ✭✭
    #1623 August, 2019, 05:42 pm.

    @HPWUMicah THANK YOU! 👍️

    As one of the people without a magnetometer in my phone, I was beginning to despair at the lack of acknowledgement of this issue - please note that the report a bug thread @Filuren linked has more comments than any other bug report thread, and this isn't even mentioned in the known issues lists!

    A gyro is much more universal than a compass/magnetometer and I believe that an option to just jump straight through the portkey and use gyro for differential movement would be a reasonably simple fix for a lot of people. In the short term though, can I please urge you to consider a solution for those of us with this issue to being locked out of the Brilliant Event tasks because of the 'unlock 3 portmanteau' type tasks? I was only able to get 1 stage into the tasks because of this. I understand that portkeys are a big part of the game and you wouldn't want to remove them from the tasks, but if we could at least have a delete button for already unlocked portkeys so we could clear boots from our portmanteau slots and unlock new ones, this would mean we weren't quite so disadvantaged!

  • JulieJubzJulieJubz Posts: 534 ✭✭✭✭
    #1723 August, 2019, 08:10 pm.

    @Craeft LOL 😂

  • ApplePineMNApplePineMN Posts: 1
    #1819 September, 2019, 05:14 am.

    I had this problem with the iPhone X I couldn’t even use AR. I couldn’t go in through my privacy settings to camera and change it because WU didn’t show up I have been so beyond frustrated but I took Andromeduss advice and it worked I went through all the steps before and couldn’t access my camera got to use a Portkey for the first time tonight thank you fellow Wizards and Witches for the help and input.. I had done a screen recording of me trying to access my camera and posted it on a HP FB page no one could help thanks again

  • KingZogKingZog Posts: 16 ✭✭
    #1929 September, 2019, 03:51 pm.

    @HPWUMicah re comment #11, any news? I realise that this isn't a trivial fix because there are a bunch of variables to consider, but almost 6 weeks on from your comment, with a new release in the meanwhile, it's still not even listed in Known Issues.

    This is getting a bit depressing. Those of us unable to open Portkeys are at a massive disadvantage in many ways. We have a new Brilliant Event coming soon, and in the last one those of us with this issue were only able to get 7/32 RSBs, which is pretty crippling. Indeed that IS a trivial fix, because if we could just delete already unlocked portkeys, we'd still suffer from not being able to get the portkey rewards, but at least we wouldn't be locked out of tasks requiring unlocking more.

    Any chance you could throw us a bone here?

  • FilurenFiluren Posts: 35 ✭✭
    #2002 October, 2019, 04:26 pm.

    As usual, I agree with @KingZog, especially as I am currently on the "unlock 1 precious portkey portmanteau" SOS task, which is currently impossible for me to do.

    Also wouldn't mind an update about where you at.

    Btw, what shape/size is the blue border for the portkeys supposed to be? I've seen a lot of pictures and videos where it's a square, but it's like a octagon shape for me?

  • OmaLaurieOmaLaurie Posts: 10 ✭✭
    #2103 October, 2019, 01:58 am.

    @Andromeduss, thank you so much for the suggestion about reinstalling the app. I got a new iPad and was flummoxed over no camera access for portkeys. Problem solved. 👏👍

  • KingZogKingZog Posts: 16 ✭✭
    #2209 October, 2019, 10:34 pm.

    @HPWULola, as Micah doesn't seem to be posting at the moment, any chance you could give us that update? 7 weeks on from "escalated internally for review" there is still no word, not even a listing in known issues. This is one of the most widely commented and reported bugs on this board, please can you at least give us an update? We're in yet another Brilliant event where those of us with this problem are losing out badly because WE CANNOT COMPLETE THE PORTKEY TASKS.


    The majority of phones suffering from this issue with a lack of compass have a gyroscope, this potentially could be as simple a fix as using sensor.TYPE_GAME_ROTATION_VECTOR rather than sensor.TYPE_GEOMAGNETIC_ROTATION_VECTOR if the compass sensor isn't present, and supplying a dummy starting orientation.


    However there is a really simple fix that you could give us that would at least not make us suffer so much from this problem. LET US DELETE UNLOCKED PORTKEYS. Not asking for a delete for those that have not yet been unlocked, but I, like many others have 8 unlocked portkeys filling the portkey slots, and cannot pick up any more. As there are unlock portkey tasks in the Brilliant event, we cannot complete these events. Being able to delete some already unlocked portkeys so we could pick up the new 3km ones and unlock those too would at least mean we weren't missing out on so many of those hard to get Restricted Section Books.

Sign In or Register to comment.