I downloaded the 2.15.0 Update from the Galaxy Store and I get a device incompatible error

HPWUrobertHPWUrobert Posts: 711 admin
in Report a Bug #1 latest comment 18 September, 2020, 01:35 pm.

Players with Samsung devices who have downloaded the 2.15.0 Update from the Galaxy Store may get a device incompatible error even if their device is compatible. Uninstall this version and download the updated version that is available in the Galaxy Store to resolve the error. Players can also download the 2.15.0 Update from the Google Play Store.

Reply
0
0 votes

New · Last Updated

Comments

  • nCodernCoder Posts: 27 ✭✭
    #217 September, 2020, 09:52 pm.
  • lirsenlirsen Posts: 5 ✭✭
    #318 September, 2020, 01:35 pm.

    Same problem


    Samsung A50 with android 10

  • nCodernCoder Posts: 27 ✭✭
    #418 September, 2020, 01:35 pm.

    Samsung S10E with android 10

    I see these lines on app start up (attached) seems like a test version ? Installed from samsung app store


    Update: new update from galaxy store fixes the problem.

Sign In or Register to comment.